Problem-Cycle start light stays on and the program starts but it does not go past first line.

Question-

Machine is a Mitsubishi MHC-50 with a mitsubishi M300 control. When trying to run a program after zero returning the machine. The cycle start light stays on and the program stops on the first line in the program and eventually after 3 minutes alarms with (MST function time over).
After running test programs in MDI just doing baxis clamp unclamp commands M10 M11. I found that as soon as I zero retun b axis it inhibits or stops running any MDI functions. However if any alarms or estop condition occurs you are then able run commands again. I looked at the droop error and found it to be zero at this time.

-Answer

What I found was the b axis when clamping had high droop or following error when clamping. The following error varied and sometimes the machine would run fine. If the machine is E stopped after zero returning program can be started and will run. I must have checked it the first time after an alarm or estop condition. If B axis is indexed machine will continue to run. But because the following error is so high it will not allow the program to run when restarted. Sounds strange but to fix problem I just changed the gridshift by the amount of the following error. powered the cnc machine down and back up. Then rezeroed the machine and then everything ran ok.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s