Tack generator alarm & Y-axis Excess error on a Fanuc O-M control

The alarm was on Y-axis. After staying powered on for about 10 minutes, with the machine not even running a Y-axis Excess error and tack generator alarm on a Fanuc O-M control would occur. The drive also showed these LED alarms on them though after testing several times, sometimes only one of the other LEDs would be on.

Checked all connections. Looked for maybe a heat problem. Left the cabinet doors open checked fans and connections.

CNC problem resolution

The  X-axis drive and Y-axis drive were the same so I swapped the encoder feedback cables and motor leads. The problem stayed with the drive. I then swapped just the top board on the two drives and found that the problem went with the board.  Ordered up a top board for about $3000 and replaced. Problems were gone.

Advertisements

One thought on “Tack generator alarm & Y-axis Excess error on a Fanuc O-M control

  1. Dear sir
    we have gildemeister machine model ct200
    in this machine problame is we on the m/c m/c showing alaram 1037 TR HOME ERR.please help us how to solve this problam
    thank you.
    best regards
    anis siddiqui

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s